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KB: WebWatchBot Service's User Account
SYMPTOMS
- You receive the error "A connection to the server could not be established", though
with a web browser, the website loads without error or significant delay.
- The drive cannot be queried.
- Cannot query performance counters local and/or remote.
- Cannot query a process local and/or remote.
- Cannot query a service local and/or remote.
- Ping returns 9999 in WebWatchBot, but not from command line.
CAUSE
- By default, the WebWatchBot service logs on with the local SYSTEM
user account.
- The local SYSTEM account does not have permission to use network resources.
- The local SYSTEM account does not have permission to access the registry.
RESOLUTION/WORKAROUND
To change the user account of the WebWatchBot Service:
- For version 5.0.4 and older: Delete log files and saved output (This
is necessary to ensure that the logs and output do not retain permissions
from the old user account):
- Open WebWatchBot Manager
- Stop the WebWatchBot Service: Tools -> Stop Service
- Select from the menu: Help -> ExclamationSoft Support -> View Data Folder
- When the Windows Explorer/My Computer window opens, close WebWatchBot Manager.
- Select all of the numbered folders and delete. This will only delete log
files and last saved output and your data will remain intact.
- Close the window
- Start (Windows Start Button)
- Control Panel
- Administrative Tools
- Services
- Find "WWBServer" (the WebWatchBot Service name)
- Stop the service
- Right-click on WWBServer and select "Properties"
- Click the "Log on" tab.
- Select the "This account tab"
- Enter the user account and password. You should enter a user account that has
high enough privilege to create, modify, read and write to files on the computer,
send email, and access network resources.
- Click OK
- Start WebWatchBot Manager.
- When prompted, start the WebWatchBot service.
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